cgwooky

5 replies · posted

Modeling A Sci-Fi Crate - Homework Submission

Took a day doing this assignment over & over so I could run into problems & try to solve them. On this one, I was never able to resolve why the top-corner vertex bevels that hold the y-shaped chrome w/green ball wouldn't shade flat. I went through & cleared the seams, cleared the creases, cleared the bevels, shaded flat, marked sharp, did the same for all verts, edges & faces - yet couldn't get it to look like the bottom-corner "legs"! I was going for a disco-ball effect using shaded flat only in those areas for contrast, oh well! I restarted Blender multiple times, saved quit & restarted, but nothing fixed it. Yes, I tried to merge all verts & edges in the area to confirm there weren't doubles. Made a couple holograms on the top & to the side & just threw a scene together real quick just to have it placed somewhere not that it actually adds to story or anything. Really just did this to go through troubleshooting modeling.

    • crew

      Very cool result. Nice work! 

      There are a lot of reasons a surface might not shade smooth, but not any that I can think of where it wouldn't shade flat. Perhaps it has a subdiv modifier that's set too high, so there are enough faces for it to appear smooth? 

    • crew

      Try selecting that face in edit mode, right click and shade flat or CTRL + F > Shade Flat. As jlampel  mentioned there are many reasons for this. One thing you could check is your normals, in the overlays menu turn on face orientation, blue is the outside face and red is inside, if you see red where there should be blue, select the red face and press SHIFT + N to recalculate the face.

    • jlampel I've never seen, it's apparently that way only in Render view, Eevee shows how it should appear. I didn't use a subdivide modifier on this object, the "problem corner" is a vertex-bevel is why it has so many faces. adrian2301 Thank you! I did try "ctrl + f" to clear sharp/mark sharp/shade flat, but normals are facing the right way. To note, that's all 1 mesh using the mirror modifier, there's no bevel modifiers

    • crew

      I think you may have some convex faces.

      Here I give an example of a bevelled vertex on a cube. Notice the face circled in the first image (I use this face as its the most obvious, but they will probably all have, to some degree, the same issue), looking from an acute angle (middle), you can see the face is not flat, an easy solution is to select the two vertices as shown in the last image and CTRL + J to join with an edge to make triangles.

      You could select all the faces and CTRL + T to triangulate all the faces at once, but you will have to check the edge is added perpendicular to the angle of the curve.

      Hope this helps.