coyo (coyohti)

9 answers · asked @ video mark 10:46 · Lesson: Laying Out UVs · Course: Modeling, Texturing and Shading a Treasure Chest in Blender 2.8

Alt-click does not disable all modifier (2.9)

SOLUTION: Disabling "Emulate 3 Button Mouse" in Preferences re-enables the ability to use the Copy to Selected alt-click shortcut.

I tried doing the select all, then alt-clicking the "display modifier in viewport" icon and it does nothing. I'm using 2.9 and actually using Kent's file from the downloads since I wanted to skip ahead to the UV unwrapping bit.

Am I doing something wrong or was this behavior changed in 2.9?


  • try ctrl L it brings up Linked data, choose modifiers

    • Hi Karen, thanks for your reply. Ctrl-L gives one the option to link modifiers. That's not what I'm doing. At that part of the video Kent selects all and then, by alt-clicking the "display modifier in viewport" icon in the mirror modifier, is able to disable that option for all selected objects with a mirror modifier. Currently, that's not the behavior I'm getting with (as far as I can tell) the same process.

    • Sorry I should say you remove the modifier off off 1.  then select the others and with the original with no modifiers on it as the "active" then press ctrl L and choose modifiers. it will make the others the same.  You add or remove the same way. 

    • I can remove them that way but I just want to disable them temporarily. Unless I'm missing something?

    • Disable on the active mesh and it will disable all of them using ctrl L

  • While I still don't know what happened to the ALT-click shortcut in 2.9 I have discovered how to accomplish the same thing via menus.

    • Select all, and then make an object with the modifier you wish to toggle the active object, as shown in the video.
    • Toggle the Viewport Display icon.
    • Right-click and choose "Copy from Selected" from the resulting menu.


    This copies the toggle status to any selected object with the modifier without applying or otherwise modifying data on objects that don't.


  • SOLUTION

    The culprit seems to be "Emulate 3 Button Mouse" but since I need to use that to make Blender and my Cintiq play nice together I will have to use the right-click menu and Copy to Selected instead.