danmelt

4 answers · asked · Lesson: Painting Base Colors · Course: Building Modular Game Assets

Fill brush leaving gaps

Hello, great tutorial--really learning a lot!  I've been using v2.81a and it's been a little more time-consuming finding the commands in the newer version, but I'm getting there...

I've been struggling with an issue where the fill brush isn't filling the selected UV space completely. There are jagged seams where differing colors meet.  I initially thought the bleed setting would resolve the issue, but haven't been able to come up with a fix.  

I realize this tutorial is based on an older version,  but does anyone have any suggestions as to how I may go about resolving this?  


Thanks in advance.


  • ddanmelt I guess I would want to see more pictures of the issue or perhaps a link to your blend file to see what is going on. It's hard to tell what you are filling there. I think you are talking about the transition from the dark to the light section?

    I like the using Paint Mask approach to fill everything that I want to fill but only on faces that were selected in edit mode. I find that if I want more control I can have the Image editor open (make sure it is set to Paint Mode) and use the fill tool there and you will be able to adjust the "Fill Threshold" in the Brush Settings section on the 'N' Panel. That will determine "how much" to fill.

    I usually finish up with a soften brush when I can't hide harsh edges and want to smooth the transition across more pixels between two harsh color zones.

  • Shawn, thanks for the tips.  Yes, in face selection mode, I found the fill had issues with completely filling faces when there were adjacent edges at odd angles.  I ended up marking seams for these faces and performed the UV unwrap again.   

    This was the ramp mesh--I probably went to extremes to solve, but the results were what I was hoping for--I'll employ your suggestions moving forward.  

    Thanks again!




    • Oh yeah I forgot about the UV unwrap option. That is definitely a great place to start with. I presumed the UV's weren't the problem.

      Your result looks great though.

    • crew

      It looks like you've solved this but here's my 2 cents: The jagged line is a result of your texture resolution. The smaller the texture the more jagged and pixelated. So you could have kept the UVs how you had them initially and either A) scaled up the island to acquire more texel density or B) increase the texture resolution as a whole.

      Though as you've found, cutting a UV seam in that location is another perfectly valid way to solve it. Good thinking.