snowingname

5 answers · asked · Lesson: Modeling Trim · Course: Interior Architectural Vizualization

Cant snap to grid proberly

Hey,
I can't snap to the grid. I'm using Blender 2.82 and its only snapping to the big grids. Even when I press shift it's not working. I also enabled increment snapping. The second problem I'm running into is that I cant use selection to the grid, because there appears a similar problem and the "vertex" of the curve is snapping to the big grid, not the little ones.
Hopes that makes sense. :P

before snapping

after


  • Hi ssnowingname ! I can't see your screenshots because images are not loading this morning for some reason but I have had that problem myself and I got around it by using Orthographic view and not Perspective. Give that a shot.

    • That was a fast answer! Thank you a lot gcs_dev this worked out well. 

      have a n1 week

    • Excellent! I'm glad it worked.

    • ssnowingname  as ggcs_dev pointed out the grid snapping defaults to a much more coarse snap on any views besides orthographic,

      One of the benefits of Orthographic is that the grid is adaptive to the level of zoom and gets more resolution the more you zoom in (when in orthographic view only) 

      Holding down the Shift key switches over to an even more fine resolution snapping as you seem to know about. This fine snap option actually snaps to the number of subdivisions that the grid has. The default grid is 1m x 1m with 10 subdivisions. So, holding shift will snap to 0.1m increments, whereas coarse snapping will snap to 1m increments.


      However, if you find the need to get more resolution on the grid sizing in perspective view then you can change the grid size and that should make snapping get more resolution durin. You can do this in the Viewport Overlays menu in the Header (icon looks like 2 overlapping circles).

      The grid scale is at the top under the “Guides” section. I personally  recommend adjusting it to finite values like 0.5 or 0.1 so when you snap you have clean distances still (scale of 1 means grid scale is 1m x 1m; scale of 0.5 means grid is 0.5m x 0.5m). But you can make some very custom workflows with this and take advantage of it for more unique values.

      One thing that has me scratching my head is why subdivisions is greyed out. Do you know why this is jlampel ?

    • Oh wait looks like it was working in Blender 2.8  but then disabled for Metric and Imperial units since 2.81.
      if you change the units to “None” supposedly it will stop being greyed out (but only while in orthographic view). There is commentary on the dev 👾 pages:


      https://developer.blender.org/T70764


      I guess it messes up distance units and that’s why it is turned off when they are active.