joekay

13 answers · asked · Lesson: Setup & Begin Painting · Course: Modeling, Texturing and Shading a Treasure Chest in Blender 2.8

Lock is partly untextured and looks different

What's wrong with it and how do i fix it?

  • I'm not sure what you want, but you have to be very careful with what keys you press, because many are hotkeys and you might end up doing things you don't want.

    For instance you are at the last frame of the animation (Frame 250) and I bet you didn't do that on purpose;)

    So, are you aware that you are in Local View? Numpad / toggles Local View on and off, or go to View > Local View > Toggle Local View.

    If something is missing in Edit Mode, maybe you hid it with H. Alt H un-hides (shows) everything....

    • Thank you for the reply. I edited my question to make it more clear. In the viewport it looks normal, and nothing is hidden. Why does it look like this when rendering?

    • Could you post a screenshot of the whole interface (not the render), with the Shader Editor open, the 3D View , with the lock selected in Edit Mode. And in the Viewport Overlays, under Geometry, select Face Orientation.

      Not sure if I'll be able to see what's wrong, but it's worth a try;)

    • Here it is

    • O.k. First of all, your chest Color is not connected to the Principled BSDF.

      Let's try this:  in Object Mode select everything, go into Edit Mode and select everything and make sure you have the UV Editor open. Also make the Outliner (where the Collections and stuff are) larger. You can get rid of the Face Orientation now.

    • Okay I've done that. Do you need me to screenshot it?

    • Yes please. Sorry that I wasn't clear about that;)

    • Done

    • What is Cube.008? It is not visible in the viewport, but might still render. Enable the render icon (camera) in the Outliner, so you can see when something is rendered and when not:

    • Oh it's just the start of a new lock seeing as I assumed the current one is broken so i decided to start a new one. I haven't rendered since I added it in

    • Are you sure there is nothing else where the lock is? It looks like two objects in more or less the same place are being rendered.

      (Do I understand correctly that you'd expect that render to be completely brown?)

    • I'll double check but I'm sure there isn't. If not I'll try again. Thank you for your help

    • If you can't get it to work, you can upload your .blend to Dropbox or some other cloud service and post a link here.