Felix B (xylef1)

1 answer · asked @ video mark 1:35 · Lesson: Viewport Navigation · Course: Moving from Blender 2.7 to 2.8

Tilde action on german keyboard

Hello there,

i can't access the pie menus with the tilde "~" keys on my keyboard as shown in the video
( lesson: "Viewport Navigation" minute: 1:35) because i am from Germany and my keyboard has a german layout. In germany the tilde key is located left from the enter button and can only be accesed with strg+alt. In Blender even using "Strg+Alt+tilde" it does nothing. I also can't find an option to change this in the keymap properties. Never used these menus in Blender 2.7 and wanted to finally learn that workflow. Is there any way to change the tilde keys to something else (or is it located anywhere else) ?

  • xxylef1  Hi Felix, I also have a german keyboard and the tilde is not working (also with some nordic keyboards as it seems).

    Personally, I don't miss it, but if you want that behavior, you'll have to assign your own shortcuts and then you can have both behaviors, each with its own shortcut.

    To do that (it's a hack...), go to Preferences > Addons > Pie Menu: 3D viewport Pie Menus and enable these two:

    That already gives you the behavior, but the shortcuts are terrible (Q overrides your quick favorites shortcut!).

    So you'll have to change them (to whatever you like):

    Change the CTRL Spacebar and the Q.